blob: e06bdf02ec165e004ab0536f53a52ccea3e87701 [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001SUMMARY = "The extensible, standards compliant build backend used by Hatch"
Andrew Geissler615f2f12022-07-15 14:00:58 -05002HOMEPAGE = "https://hatch.pypa.io/"
Andrew Geissler78b72792022-06-14 06:47:25 -05003LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
5
6inherit pypi python_hatchling
7
8DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native"
9DEPENDS:remove:class-native = "python3-hatchling-native"
10
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050011SRC_URI[sha256sum] = "bd6e8505de511ac4217ff50927f6d1845494608e401e63a62b830c31fb613544"
Andrew Geissler78b72792022-06-14 06:47:25 -050012
13do_compile:prepend() {
14 export PYTHONPATH=src
15}
16
17BBCLASSEXTEND = "native nativesdk"