blob: 66e0affc64b7dfc33ad3d7d393d85fb1bdea7b38 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "An implementation of JSON Schema validation for Python"
2HOMEPAGE = "https://github.com/Julian/jsonschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
5 file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
6
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05007SRC_URI[sha256sum] = "df10e65c8f3687a48e93d0d348ce0ce5f897b5a28e9bbcbbe8f7c7eaf019e850"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Andrew Geissler615f2f12022-07-15 14:00:58 -05009inherit pypi python_hatchling
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050011PACKAGES =+ "${PN}-tests"
12FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests"
13
Andrew Geissler615f2f12022-07-15 14:00:58 -050014DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16PACKAGECONFIG ??= "format"
17PACKAGECONFIG[format] = ",,,\
18 ${PYTHON_PN}-idna \
19 ${PYTHON_PN}-jsonpointer \
20 ${PYTHON_PN}-webcolors \
21 ${PYTHON_PN}-rfc3987 \
22 ${PYTHON_PN}-strict-rfc3339 \
23"
24PACKAGECONFIG[nongpl] = ",,,\
25 ${PYTHON_PN}-idna \
26 ${PYTHON_PN}-jsonpointer \
27 ${PYTHON_PN}-webcolors \
28 ${PYTHON_PN}-rfc3986-validator \
29 ${PYTHON_PN}-rfc3339-validator \
30"
31
32RDEPENDS:${PN} += " \
33 ${PYTHON_PN}-attrs \
34 ${PYTHON_PN}-core \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-importlib-metadata \
37 ${PYTHON_PN}-io \
38 ${PYTHON_PN}-json \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
Andrew Geissler9aee5002022-03-30 16:27:02 +000041 ${PYTHON_PN}-pprint \
42 ${PYTHON_PN}-pyrsistent \
Andrew Geissler9aee5002022-03-30 16:27:02 +000043 ${PYTHON_PN}-zipp \
44"
45
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050046RDEPENDS:${PN}-tests = "${PN}"
47
Andrew Geissler9aee5002022-03-30 16:27:02 +000048BBCLASSEXTEND = "native nativesdk"