blob: ad1149597f3aa056027765c7571ceeb5601219d9 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Software Construction tool (make/autotools replacement)"
2HOMEPAGE = "https://github.com/SCons/scons"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d903b0b8027f461402bac9b5169b36f7"
6
7SRC_URI += " file://0001-Fix-man-page-installation.patch"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05008SRC_URI[sha256sum] = "7703c4e9d2200b4854a31800c1dbd4587e1fa86e75f58795c740bcfa7eca7eaa"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10PYPI_PACKAGE = "SCons"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN}:class-target = "\
15 python3-core \
16 python3-compression \
17 python3-fcntl \
18 python3-importlib-metadata \
19 python3-io \
20 python3-json \
21 python3-shell \
22 python3-pickle \
23 python3-pkg-resources \
24 python3-pprint \
25 "
26
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000027do_install:append() {
28 install -d ${D}${mandir}/man1
29 mv ${D}${prefix}/scons*.1 ${D}${mandir}/man1/
30}
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031
32do_install:append:class-native() {
33 create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
34}
35
36BBCLASSEXTEND = "native"