blob: 24d7918bf9d0444f95d457d27be075f1f735ae9d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665"
7
8DEPENDS = "e2fsprogs-native"
9
Andrew Geissler78b72792022-06-14 06:47:25 -050010PACKAGECONFIG ?= "zlib bz2 xz zstd"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12PACKAGECONFIG:append:class-target = "\
13 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
14"
15
16DEPENDS_BZIP2 = "bzip2-replacement-native"
17DEPENDS_BZIP2:class-target = "bzip2"
18
19PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
20PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
21PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
22PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
23PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz,"
24PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
25PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
26PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
27PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
28PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
29PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
30PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,"
31PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd,"
32
33EXTRA_OECONF += "--enable-largefile"
34
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050035SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
36 file://0001-libarchive-Do-not-include-sys-mount.h-when-linux-fs..patch \
37 "
Andrew Geissler9aee5002022-03-30 16:27:02 +000038UPSTREAM_CHECK_URI = "http://libarchive.org/"
39
Patrick Williams58776372022-04-13 09:07:35 -050040SRC_URI[sha256sum] = "c676146577d989189940f1959d9e3980d28513d74eedfbc6b7f15ea45fe54ee2"
Andrew Geissler9aee5002022-03-30 16:27:02 +000041
42inherit autotools update-alternatives pkgconfig
43
44CPPFLAGS += "-I${WORKDIR}/extra-includes"
45
46do_configure[cleandirs] += "${WORKDIR}/extra-includes"
47do_configure:prepend() {
48 # We just need the headers for some type constants, so no need to
49 # build all of e2fsprogs for the target
50 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
51}
52
53ALTERNATIVE_PRIORITY = "80"
54
55PACKAGES =+ "bsdtar"
56FILES:bsdtar = "${bindir}/bsdtar"
57
58ALTERNATIVE:bsdtar = "tar"
59ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
60ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
61
62PACKAGES =+ "bsdcpio"
63FILES:bsdcpio = "${bindir}/bsdcpio"
64
65ALTERNATIVE:bsdcpio = "cpio"
66ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
67ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
68
69BBCLASSEXTEND = "native nativesdk"