blob: d4f5b8d0cb5f7e4272e81294ab1f82b0682a71b6 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "This script upgrades packages automatically and unattended."
2DESCRIPTION = "The purpose of unattended-upgrades is to keep the computer current with the latest security (and other) updates automatically."
3HOMEPAGE = "https://wiki.debian.org/UnattendedUpgrades"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
6 file://debian/copyright;md5=62b5f2ac0ede901fb245eefbe54c181f"
7
8SRC_URI = "git://github.com/mvo5/unattended-upgrades.git;protocol=https;branch=master \
9 file://0001-unattended-upgrade-Remove-distro_info-usage-to-check.patch \
Andrew Geissler78b72792022-06-14 06:47:25 -050010 file://0001-setup.py-Disable-autodection-of-modules.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011 "
12
13SRCREV = "c6db6fad26a2b83ba301b52ff5dee98cef7558ca"
14
15S = "${WORKDIR}/git"
16
Andrew Geissler9aee5002022-03-30 16:27:02 +000017inherit setuptools3_legacy
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
19DEPENDS += "apt intltool-native python3-distutils-extra-native"
20RDEPENDS:${PN} += "apt lsb-release python3-apt python3-core python3-datetime python3-email python3-fcntl python3-io python3-logging python3-stringold python3-syslog"
21
Andrew Geissler9aee5002022-03-30 16:27:02 +000022do_configure:prepend () {
23 install -Dm 0644 ${S}/data/50unattended-upgrades.Debian ${S}/data/50unattended-upgrades
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024}
25
26do_install:append () {
27 # fix bad installation path's
28 mv -v ${D}/usr/usr/share/* ${D}/usr/share/
29 rm -r ${D}/usr/usr
30}
31
Andrew Geissler9aee5002022-03-30 16:27:02 +000032FILES:${PN} = "${bindir} ${exec_prefix}/etc ${libdir} ${datadir} ${nonarch_libdir}"