blob: 0dd353bfee54b8c78eb7ca2d7525f691a340cec7 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "python bindings for the lz4 compression library by Yann Collet"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
5
6DEPENDS += " \
7 lz4 \
8 ${PYTHON_PN}-setuptools-scm-native \
9 ${PYTHON_PN}-pkgconfig-native \
10"
11
12SRC_URI += "file://run-ptest"
13
Andrew Geissler78b72792022-06-14 06:47:25 -050014SRC_URI[sha256sum] = "efdfec2175715bf2d814ed72a7a185406f3456464eb3f343db1b87ed813e039c"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16inherit pkgconfig pypi python_setuptools_build_meta ptest
17
18RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest ${PYTHON_PN}-multiprocessing ${PYTHON_PN}-psutil"
19
20do_install_ptest() {
21 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
22 # The stream API is experimental and not enabled yet, so don't ship the test suite
23 rm -rf ${D}${PTEST_PATH}/tests/stream
24}
25
26BBCLASSEXTEND = "native nativesdk"