blob: 55061c9103ede2bcc25153c7ef5f5953fad2b72d [file] [log] [blame]
Patrick Williams03907ee2022-05-01 06:28:52 -05001SUMMARY = "Provider for integration of TPM 2.0 to OpenSSL 3.0"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b75785ac083d3c3ca04d99d9e4e1fbab"
4
5DEPENDS = "autoconf-archive-native tpm2-tss openssl"
6
7SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz"
8
9SRC_URI[sha256sum] = "eedcc0b72ad6d232e6f9f55a780290c4d33a4d06efca9314f8a36d7384eb1dfc"
10
11inherit autotools pkgconfig
12
13do_configure:prepend() {
14 # do not extract the version number from git
15 sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac
16}
17
18FILES:${PN} = "\
19 ${libdir}/ossl-modules/tpm2.so"