blob: 7e27b5b018d106cf10e0b665e29abb1706e71f68 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception & MIT & OpenSSL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=e5a9227de4cb6afb5d35ed7b0fdf480d"
5
6DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.4;protocol=https"
Patrick Williams03907ee2022-05-01 06:28:52 -05009SRCREV = "465bbf88ea939a965fbcbade72870c61f815e457"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16 -DBUILD_CLAR=OFF \
17 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
18 -DLIB_INSTALL_DIR=${libdir} \
19 -DREGEX_BACKEND='pcre2' \
20"
21
22BBCLASSEXTEND = "native"