blob: 062ded9a18103d2be288d9e0041bcf922b8d2a58 [file] [log] [blame]
Patrick Williams2194f502022-10-16 14:26:09 -05001SUMMARY = "A suite of libcamera-based apps for the Raspberry Pi"
2DESCRIPTION = "This is a small suite of libcamera-based apps that aim to \
3copy the functionality of the existing \"raspicam\" apps."
4HOMEPAGE = "https://github.com/raspberrypi/libcamera-apps"
5SECTION = "console/utils"
6
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://license.txt;md5=a0013d1b383d72ba4bdc5b750e7d1d77"
9
10SRC_URI = "\
11 git://github.com/raspberrypi/libcamera-apps.git;protocol=https;branch=main \
Andrew Geisslerdc9d6142023-05-19 09:38:37 -050012 file://0001-utils-version.py-use-usr-bin-env-in-shebang.patch \
Patrick Williams2194f502022-10-16 14:26:09 -050013"
Andrew Geisslerdc9d6142023-05-19 09:38:37 -050014PV = "1.1.2+git${SRCPV}"
15SRCREV = "12098520a3dec36ba796655baac7efece457f8d8"
Patrick Williams2194f502022-10-16 14:26:09 -050016
17S = "${WORKDIR}/git"
18
19COMPATIBLE_MACHINE = "^rpi$"
20
21DEPENDS = "libcamera libexif jpeg tiff libpng boost"
22
23inherit cmake pkgconfig
24
25EXTRA_OECMAKE = "\
26 -DCMAKE_BUILD_TYPE=Release \
27 -DBoost_INCLUDE_DIR=${STAGING_INCDIR} \
28 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR} \
29"
30
Andrew Geisslerdc9d6142023-05-19 09:38:37 -050031LIBCAMERA_ARCH = "${TARGET_ARCH}"
32LIBCAMERA_ARCH:aarch64 = "arm64"
33LIBCAMERA_ARCH:arm = "armv8-neon"
34EXTRA_OECMAKE += "-DENABLE_COMPILE_FLAGS_FOR_TARGET=${LIBCAMERA_ARCH}"
Patrick Williams2194f502022-10-16 14:26:09 -050035
36PACKAGECONFIG[x11] = "-DENABLE_X11=1,-DENABLE_X11=0"
37PACKAGECONFIG[qt] = "-DENABLE_QT=1,-DENABLE_QT=0"
38PACKAGECONFIG[opencv] = "-DENABLE_OPENCV=1,-DENABLE_OPENCV=0"
39PACKAGECONFIG[tensorflow-lite] = "-DENABLE_TFLITE=1,-DENABLE_TFLITE=0"
40
Patrick Williams2194f502022-10-16 14:26:09 -050041do_install:append() {
42 # Requires python3-core which not all systems may have
Andrew Geisslerdc9d6142023-05-19 09:38:37 -050043 rm -v ${D}/${bindir}/camera-bug-report
Patrick Williams2194f502022-10-16 14:26:09 -050044}