blob: 86fe673b47ff7357712b5158867651fc8a65c4c1 [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
Brad Bishop2d39a062019-10-28 08:33:36 -04005LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f5f7c71504da070bcf4f090205ce1080"
James Feiste3322992018-10-04 16:15:37 -07006
Brad Bishope42b3e32020-01-15 22:08:42 -05007SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1"
James Feiste3322992018-10-04 16:15:37 -07008
Brad Bishope42b3e32020-01-15 22:08:42 -05009SRCREV = "e7b3b40b5a95bc74b9a7f662830a27c49ffc01b4"
James Feiste3322992018-10-04 16:15:37 -070010
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
16
17# nlohmann-json is a header only C++ library, so the main package will be empty.
18
19RDEPENDS_${PN}-dev = ""
20
21BBCLASSEXTEND = "native nativesdk"
James Feistcb07cdf2018-10-11 13:47:04 -070022
23# other packages commonly reference the file directly as "json.hpp"
24# create symlink to allow this usage
25do_install_append() {
26 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
27}