blob: e8d187389af161ade272522b528ac98f73208f2e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Yet Another Flash File System"
2DESCRIPTION = "Tools for managing 'yaffs2' file systems."
3
4SECTION = "base"
5HOMEPAGE = "http://www.yaffs.net"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561"
9
10PV = "0.0+git${SRCPV}"
11
12DEPENDS = "mtd-utils"
13
14# Source is the HEAD of master branch at the time of writing this recipe
Patrick Williamsddad1a12017-02-23 20:36:32 -060015SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \
16 file://makefile-add-ldflags.patch \
17 "
18
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578"
20S = "${WORKDIR}/git"
21
22CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
23EXTRA_OEMAKE = "-e MAKEFLAGS="
24
25do_compile() {
26 cd utils && oe_runmake
27}
28
29INSTALL_FILES = "mkyaffsimage \
30 mkyaffs2image \
31 "
32do_install() {
33 install -d ${D}${sbindir}/
34 for i in ${INSTALL_FILES}; do
35 install -m 0755 utils/$i ${D}${sbindir}/
36 done
37}
38
39BBCLASSEXTEND = "native"