blob: 5052b36fc339247239521b19029e90ce5bab3374 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
7 librsvg libwmf-native gtkmathview asio gtk+ evolution-data-server \
8 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)}"
9RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
10 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
11RCONFLICTS_${PN} = "${PN}-embedded"
12
13SRC_URI = " \
14 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
15 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060016 file://0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017"
18
19LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
20
21SRC_URI[md5sum] = "f3f8052e7b4979a43b75775a381e6cb8"
22SRC_URI[sha256sum] = "e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6"
23
24#want 3.x from 3.x.y for the installation directory
25SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
26
27inherit autotools-brokensep pkgconfig
28
29PACKAGECONFIG ??= " \
30 collab-backend-xmpp collab-backend-tcp \
31 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'libical', '', d)} \
32"
33PACKAGECONFIG[libical] = "--with-libical,--without-libical,libical raptor2"
34PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
35PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
36PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
37PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
38PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
39PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
40
41EXTRA_OECONF = " --disable-static \
42 --enable-plugins \
43 --enable-clipart \
44 --enable-templates \
45 --without-gnomevfs \
46 --with-gtk2 \
47 --with-libwmf-config=${STAGING_DIR} \
48"
49
50do_compile() {
51 cd goffice-bits2
52 make goffice-paths.h
53 make libgoffice.la
54 cd ${B}
55 oe_runmake
56}
57
58PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
59
60FILES_${PN} += " \
61 ${libdir}/lib${PN}-*.so \
62 ${datadir}/mime-info \
63 ${datadir}/icons/* \
64 ${datadir}/${PN}-${SHRT_VER}/glade \
65 ${datadir}/${PN}-${SHRT_VER}/scripts \
66 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
67 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
68 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
69 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
70 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
71 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
72 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
73 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
74 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
75 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
76 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
77 ${datadir}/${PN}-${SHRT_VER}/certs \
78 ${datadir}/${PN}-${SHRT_VER}/ui \
Patrick Williamsddad1a12017-02-23 20:36:32 -060079 ${datadir}/${PN}-${SHRT_VER}/xsl* \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050080 ${datadir}/${PN}-${SHRT_VER}/mime-info \
81 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
82"
83
84# don't steal /usr/lib/libabiword-3.0.so from ${PN}
85# in this case it's needed in ${PN}
86FILES_${PN}-dev = " \
87 ${includedir} \
88 ${libdir}/pkgconfig \
89 ${libdir}/${PN}*.la \
90 ${libdir}/lib${PN}*.la \
91 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
92"
93FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
94FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
95
96FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
97FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
98FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
99FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
100FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
101FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
102
103PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
104
105python populate_packages_prepend () {
106 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
107 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
108
109 metapkg = "abiword-meta"
110 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
111 d.setVar('FILES_' + metapkg, "")
112 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
113 metapkg_rdepends = []
114 packages = d.getVar('PACKAGES', 1).split()
115 for pkg in packages[1:]:
116 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
Patrick Williamsddad1a12017-02-23 20:36:32 -0600117 print("Modifying %s" % pkg)
Patrick Williamsb48b7b42016-08-17 15:04:38 -0500118 metapkg_rdepends.append(pkg)
119 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
120 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
121 packages.append(metapkg)
122 d.setVar('PACKAGES', ' '.join(packages))
123}
124
125FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"