blob: ab01235ec9130aaf9cb3c977b72957557c5467eb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001HOMEPAGE = "http://w1.fi/hostapd/"
2SECTION = "kernel/userland"
3LICENSE = "GPLv2 | BSD"
4LIC_FILES_CHKSUM = "file://${B}/README;md5=4d53178f44d4b38418a4fa8de365e11c"
5DEPENDS = "libnl openssl"
6SUMMARY = "User space daemon for extended IEEE 802.11 management"
7
8inherit update-rc.d systemd
9INITSCRIPT_NAME = "hostapd"
10
11SYSTEMD_SERVICE_${PN} = "hostapd.service"
12SYSTEMD_AUTO_ENABLE_${PN} = "disable"
13
14SRC_URI = " \
15 http://w1.fi/releases/hostapd-${PV}.tar.gz \
16 file://defconfig \
17 file://init \
18 file://hostapd.service \
Patrick Williamsddad1a12017-02-23 20:36:32 -060019 file://0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020"
21
22S = "${WORKDIR}/hostapd-${PV}"
23B = "${WORKDIR}/hostapd-${PV}/hostapd"
24
25do_configure() {
26 install -m 0644 ${WORKDIR}/defconfig ${B}/.config
27}
28
29do_compile() {
30 export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
31 make
32}
33
34do_install() {
35 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
36 install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
37 install -m 0755 ${B}/hostapd ${D}${sbindir}
38 install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
39 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
40 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
41 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service
42}
43
44CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
45
46SRC_URI[md5sum] = "69f9cec3f76d74f402864a43e4f8624f"
47SRC_URI[sha256sum] = "8e272d954dc0d7026c264b79b15389ec2b2c555b32970de39f506b9f463ec74a"