blob: 8ae018503171712b29c6ef87a15df8fc9ad27fad [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ltrace intercepts and records dynamic library calls"
2
3DESCRIPTION = "ltrace intercepts and records dynamic library calls \
4which are called by an executed process and the signals received by that process. \
5It can also intercept and print the system calls executed by the program.\
6"
7HOMEPAGE = "http://ltrace.org/"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
11
12PE = "1"
13PV = "7.3+git${SRCPV}"
Patrick Williamsddad1a12017-02-23 20:36:32 -060014SRCREV = "01b10e191e99d8cb147e5a2b7da8196e0ec6fb94"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16DEPENDS = "elfutils"
17RDEPENDS_${PN} = "elfutils"
Patrick Williamsddad1a12017-02-23 20:36:32 -060018SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019 file://configure-allow-to-disable-selinux-support.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060020 file://0001-replace-readdir_r-with-readdir.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021 "
22S = "${WORKDIR}/git"
23
24inherit autotools
25
26PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
27PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
28PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
29
30do_configure_prepend () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060031 ( cd ${S}; ./autogen.sh )
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032}