blob: 281dc3d422944d8f0ecefd79e92807b8604cb147 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "An implementation of the GEIS interface"
2DESCRIPTION = "An implementation of the GEIS (Gesture Engine Interface and Support) \
3interface\
4GEIS is a library for applications and toolkit programmers which \
5provides a consistent platform independent interface for any \
6system-wide input gesture recognition mechanism."
7
8HOMEPAGE = "https://launchpad.net/geis"
9
10LICENSE = "GPLv3 & LGPLv3"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \
13 file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
14"
15
16inherit autotools pkgconfig python3native lib_package distro_features_check
17
18REQUIRED_DISTRO_FEATURES = "x11"
19
20DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame"
21
Patrick Williamsddad1a12017-02-23 20:36:32 -060022SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz\
23 file://fix-indentation-for-gcc6.patch \
24"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf"
26SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb"
27
28EXTRA_OECONF = "--disable-integration-tests"
29
30FILES_${PN}-bin = "${bindir}"
31RDEPENDS_${PN}-bin = " \
Patrick Williamsddad1a12017-02-23 20:36:32 -060032 python3-argparse \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050033 python3-compression \
34 python3-core \
35 python3-crypt \
36 python3-ctypes \
37 python3-fcntl \
38 python3-misc \
39 python3-pickle \
40 python3-shell \
41 python3-stringold \
42 python3-subprocess \
43 python3-textutils \
44 python3-threading \
45"
46
47FILES_${PN} += " \
48 ${datadir}/geisview \
49 ${libdir}/${PYTHON_DIR}/site-packages/geis* \
50 ${libdir}/${PYTHON_DIR}/site-packages/_*.so \
51"
52
53FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
54
55FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
56
57FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"