blob: dcb373a1f3a0e3b0207a9b09892478b99c65f8db [file] [log] [blame]
Patrick Williams45852732022-04-02 08:58:32 -05001DESCRIPTION = "Python3 interface to the wxWidgets Cross-platform C++ GUI toolkit."
2HOMEPAGE = "http://www.wxpython.org"
3
4LICENSE = "WXwindows"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
6
Patrick Williamsde0582f2022-04-08 10:23:27 -05007inherit features_check
8
9REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"
10
Patrick Williams45852732022-04-02 08:58:32 -050011DEPENDS = "wxwidgets-native wxwidgets"
12
13PYPI_PACKAGE = "wxPython"
14
15SRC_URI += "file://add-back-option-build-base.patch \
16 file://wxgtk-fixup-build-scripts.patch \
17 file://sip-fix-override-functions.patch \
18 "
19SRC_URI[sha256sum] = "00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b6c3528"
20
21S = "${WORKDIR}/wxPython-${PV}"
22
23inherit pypi setuptools3 pkgconfig
24
25export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR}'"
26
27RDEPENDS:${PN} = "\
28 python3-difflib \
29 python3-image \
30 python3-numpy \
31 python3-pillow \
32 python3-pprint \
33 python3-pycairo \
34 python3-six \
35 python3-xml \
36"