blob: 85f7d44573b10634be7f5adb20fe69fd763e73e8 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Kernel Runtime Guard"
2DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
3kernel and detection of security vulnerability exploits against the kernel."
4SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/"
Patrick Williamsde0582f2022-04-08 10:23:27 -05006LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
8LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432"
9
10DEPENDS = "virtual/kernel elfutils"
11
Patrick Williamsde0582f2022-04-08 10:23:27 -050012SRCREV = "43db5f19fca259feb1962f6db33382348cbc8320"
13
14SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015 file://makefile_cleanup.patch "
16
Patrick Williamsde0582f2022-04-08 10:23:27 -050017S = "${WORKDIR}/git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
19inherit module kernel-module-split
20
21MAKE_TARGETS = "modules"
22
23MODULE_NAME = "p_lkrg"
24
25module_do_install() {
26 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
27 install -m 0644 ${MODULE_NAME}.ko \
28 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
29}
30
31RPROVIDES:${PN} += "kernel-module-lkrg"
32
33COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"