Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "High-Performance Asynchronous HTTP Client Library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "The Apache Serf library is a C-based HTTP client library built upon the Apache \ |
| 3 | Portable Runtime (APR) library. It multiplexes connections, running the \ |
| 4 | read/write communication asynchronously. Memory copies and transformations are \ |
| 5 | kept to a minimum to provide high performance operation." |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 6 | HOMEPAGE = "http://serf.apache.org/" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 8 | file://norpath.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 9 | file://env.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 10 | file://0002-SConstruct-Fix-path-quoting-for-.def-generator.patch \ |
| 11 | file://0003-gen_def.patch \ |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 12 | file://SConstruct.stop.creating.directories.without.sandbox-install.prefix.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 13 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "be81ef08baa2516ecda76a77adf7def7bc3227eeb578b9a33b45f7b41dc064e6" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | |
| 17 | LICENSE = "Apache-2.0" |
| 18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 19 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 20 | inherit scons |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 22 | DEPENDS += " openssl apr apr-util util-linux expat" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 23 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 24 | EXTRA_OESCONS = " \ |
| 25 | LIBDIR=${libdir} \ |
| 26 | --install-sandbox=${D} \ |
| 27 | CC="${CC}" \ |
| 28 | CFLAGS="${CFLAGS}" \ |
| 29 | LINKFLAGS="${LDFLAGS}" \ |
| 30 | APR=`which apr-1-config` \ |
| 31 | APU=`which apu-1-config` \ |
| 32 | OPENSSL="${STAGING_EXECPREFIXDIR}" \ |
| 33 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 34 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 35 | # scons creates non-reproducible archives |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append() { |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 37 | rm ${D}/${libdir}/*.a |
| 38 | } |
| 39 | |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 40 | BBCLASSEXTEND = "native nativesdk" |