blob: 54d6b73e4e81505083f90e08300a5813c1ca2ccf [file] [log] [blame]
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08001SUMMARY = "MCTP stack"
2DESCRIPTION = "MCTP library implementing the MCTP base specification"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit systemd
7inherit autotools pkgconfig
8
9HOMEPAGE = "https://github.com/openbmc/libmctp"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
12SRC_URI = "git://github.com/openbmc/libmctp \
13 file://default"
Andrew Geissler33a64102021-08-30 05:31:14 +000014SRCREV = "edebe169ebefd6410d74850bbce1ea599c347753"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080015
16DEPENDS += "autoconf-archive-native \
17 systemd \
George Liu948c7b42021-06-24 11:13:15 +080018 "
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080019
Patrick Williams12fc9392021-08-06 09:16:53 -050020SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
George Liu948c7b42021-06-24 11:13:15 +080021 mctp-demux.socket \
22 "
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080023
Andrew Jefferyd957f032021-05-12 22:31:34 +093024PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
25PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
26 --without-systemdsystemunitdir,systemd"
27
Andrew Jeffery8e0e67f2021-05-11 13:40:40 +093028PACKAGECONFIG[astlpc-raw-kcs] = "--enable-astlpc-raw-kcs,--disable-astlpc-raw-kcs,udev,udev"
29
Patrick Williams12fc9392021-08-06 09:16:53 -050030CONFFILES:${PN} = "${sysconfdir}/default/mctp"
Andrew Jefferyd957f032021-05-12 22:31:34 +093031
Patrick Williams12fc9392021-08-06 09:16:53 -050032do_install:append() {
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080033 install -d ${D}${sysconfdir}/default
34 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
35}
36
37S = "${WORKDIR}/git"