blob: f816706af92e5f634174130f77c96be059de659b [file] [log] [blame]
Milton D. Miller II0e775142016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
Gunnar Millse5b38602018-08-31 12:39:15 -05002DESCRIPTION = "Phosphor OpenBMC filesystem mount reference implementation."
Brad Bishopcd0ba722018-06-19 15:21:01 -04003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Milton D. Miller II0e775142016-01-20 14:57:54 -06005
Brad Bishopcd0ba722018-06-19 15:21:01 -04006PR = "r1"
Milton D. Miller II0e775142016-01-20 14:57:54 -06007
Brad Bishop021bba32018-07-23 15:25:34 -04008inherit allarch
9
Patrick Williams12fc9392021-08-06 09:16:53 -050010RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
Brad Bishopd94781b2018-06-19 15:24:49 -040011
Milton D. Miller II0e775142016-01-20 14:57:54 -060012S = "${WORKDIR}"
13SRC_URI += "file://obmc-init.sh"
14SRC_URI += "file://obmc-shutdown.sh"
15SRC_URI += "file://obmc-update.sh"
16SRC_URI += "file://whitelist"
17
18do_install() {
Milton D. Miller II0111a482016-03-07 14:42:50 -060019 for f in init-download-url init-options
20 do
21 if test -e $f
22 then
23 install -m 0755 ${WORKDIR}/$f ${D}/$f
24 fi
25 done
Milton D. Miller II0e775142016-01-20 14:57:54 -060026 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
27 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
28 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
29 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
30 install -d ${D}/dev
31 mknod -m 622 ${D}/dev/console c 5 1
32}
33
Patrick Williams12fc9392021-08-06 09:16:53 -050034FILES:${PN} += " /init /shutdown /update /whitelist /dev "
35FILES:${PN} += " /init-options /init-download-url "