blob: a18d6739691528d10a8ab30999373145fea544c7 [file] [log] [blame]
Sergey Solominc7419c62016-08-16 14:18:18 -05001FILES_${PN}-catalog-extralocales = \
2 "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
3PACKAGES =+ "${PN}-catalog-extralocales"
Jayanth Othayotheb5f1892017-09-21 19:50:57 -05004PACKAGECONFIG_append = " networkd coredump"
Sergey Solominc7419c62016-08-16 14:18:18 -05005PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
Joel Stanleye1c31452018-02-23 14:22:20 +10306 quotacheck kdbus ima smack polkit logind bootchart utmp \
7 manpages"
Brad Bishop11821852015-10-30 03:02:05 -04008FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
9SRC_URI += "file://default.network"
Andrew Geissler1b3762a2017-09-07 14:32:45 -050010SRC_URI += "file://service-restart-policy.conf"
Brad Bishop44a22c22016-08-15 20:16:55 -040011SRC_URI += "file://0001-Export-message_append_cmdline.patch"
Edward A. James3d6db402016-10-14 16:07:14 -050012SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
Brad Bishop8ef5fd22017-01-11 20:42:58 -050013SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
14SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
Ratan Gupta87497e82017-07-20 12:08:11 +053015#TODO upstream the below patch via below issue
16#https://github.com/openbmc/openbmc/issues/2016
17SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
Adriana Kobylak72a4a3f2017-06-04 15:41:59 -050018SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
19SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
Gunnar Mills1e445242017-11-01 14:09:04 -050020SRC_URI += "${@mf_enabled(d, 'obmc-ubi-fs', 'file://software.conf')}"
Yong Li250bde82017-12-15 21:25:05 +080021SRC_URI += "file://0008-man-update-machine-id-5-with-a-note-about-privacy-46.patch"
22SRC_URI += "file://0009-sd-id128-add-new-sd_id128_get_machine_app_specific-A.patch"
23SRC_URI += "file://0010-core-add-khash-API-to-src-basic-as-wrapper-around-ke.patch"
Brad Bishop11821852015-10-30 03:02:05 -040024
Brad Bishope3060732016-08-08 20:21:44 -040025RRECOMMENDS_${PN} += "obmc-targets"
Brad Bishop11821852015-10-30 03:02:05 -040026FILES_${PN} += "${libdir}/systemd/network/default.network"
Andrew Geissler1b3762a2017-09-07 14:32:45 -050027FILES_${PN} += "${libdir}/systemd/system.conf.d/service-restart-policy.conf"
Brad Bishop11821852015-10-30 03:02:05 -040028
Edward A. James52523132016-08-04 16:19:18 -050029EXTRA_OECONF += " --disable-hwdb"
30
Brad Bishop11821852015-10-30 03:02:05 -040031do_install_append() {
32 install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
Andrew Geissler1b3762a2017-09-07 14:32:45 -050033 install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${libdir}/systemd/system.conf.d/service-restart-policy.conf
Adriana Kobylakbbf2cb82016-01-30 11:12:10 -060034
35 #TODO Remove after this issue is resolved
36 #https://github.com/openbmc/openbmc/issues/152
37 ln -s /dev/null ${D}/etc/systemd/system/systemd-hwdb-update.service
Gunnar Mills1e445242017-11-01 14:09:04 -050038
39 # /tmp/images is the software image upload directory.
40 # It should not be deleted since it is watched by the Image Manager
41 # for new images.
42 if ${@bb.utils.contains('MACHINE_FEATURES', 'obmc-ubi-fs', 'true', 'false', d)}; then
43 install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
44 fi
Brad Bishop11821852015-10-30 03:02:05 -040045}