blob: f2063e464790f1e75d3e313025c661e9f4c12d07 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Synergy - control multiple computers with one keyboard and mouse"
2HOMEPAGE = "http://synergy-project.org"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0f366945b209c5523e39889f636af00a"
4LICENSE = "GPL-2.0"
5SECTION = "x11/utils"
6
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl"
8do_unpack_extra[depends] = "unzip-native:do_populate_sysroot"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
10# depends on virtual/libx11
11REQUIRED_DISTRO_FEATURES = "x11"
12
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013SRC_URI = "git://github.com/symless/synergy-core.git;protocol=https"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014
15# Version 1.7.4-rc8
16SRCREV ?= "588fb4b805dd452556d05dbc03fe29ea5b4e43c0"
17PV = "1.7.3+1.7.4-rc8+${SRCPV}"
18
19S = "${WORKDIR}/git"
20
21inherit cmake distro_features_check
22
23do_unpack_extra() {
24 cd ${S}/ext
25 for file in *.zip; do
26 fname="${file##*/}"
27 unzip $file -d ${fname%.*}
28 done
29}
30addtask unpack_extra after do_unpack before do_patch
31
32do_install() {
33 install -d ${D}/usr/bin
34 install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/
35}