blob: 13222e917e685644da08515ffa0277c7952f390e [file] [log] [blame]
Brad Bishope3278032016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
9inherit pythonnative
10
11FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
12
13DEPENDS += "autoconf-archive-native"
14RDEPENDS_${PN} += " \
15 python-inflection \
16 python-mako \
17 python-pyyaml \
18 "
19
20SRC_URI += "git://github.com/openbmc/sdbusplus"
21SRCREV = "ccacc4af969a70cc24f84981b5a5dde01a928d09"
22
23PACKAGECONFIG ??= "libsdbusplus"
24PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
25
26S = "${WORKDIR}/git"
27
28PACKAGECONFIG_remove_class-native = "libsdbusplus"
29PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
30
31export BUILD_SYS
32export HOST_SYS
33export STAGING_INCDIR
34export STAGING_LIBDIR
35
36BBCLASSEXTEND += "native nativesdk"