blob: 0ea7f6de97f1802a115fa48b0cef2ff0799cbf56 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
6
7inherit autotools systemd gsettings python3native gtk-icon-cache
8
9SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \
Brad Bishop2d39a062019-10-28 08:33:36 -040012 file://0002-fix-fail-to-enable-bluetooth.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040013"
14SRC_URI[md5sum] = "9de89abb31be45bdbf11f7884764a2dc"
15SRC_URI[sha256sum] = "f1eab2334e5a1587defa80900901048d14c2e8ffa8c0cff7240bc9937a61dbc3"
16
17EXTRA_OECONF = " \
Brad Bishope42b3e32020-01-15 22:08:42 -050018 --disable-appindicator \
Brad Bishop26bdd442019-08-16 17:08:17 -040019 --disable-runtime-deps-check \
20 --disable-schemas-compile \
21"
22
23SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service"
24SYSTEMD_AUTO_ENABLE_${PN} = "disable"
25
26RRECOMENDS_${PN} += "adwaita-icon-theme"
27RDEPENDS_${PN} += " \
28 python3-core \
29 python3-dbus \
30 packagegroup-tools-bluetooth \
31"
32
33PACKAGECONFIG ??= "thunar"
34PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto"
35
36FILES_${PN} += " \
37 ${datadir}/dbus-1 \
38 ${datadir}/Thunar \
39 ${systemd_user_unitdir} \
40 ${exec_prefix}${systemd_system_unitdir} \
41 ${PYTHON_SITEPACKAGES_DIR} \
42"
43
44FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
45
46# In code, path to python is a variable that is replaced with path to native version of it
47# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
48# Replace it with #!/usr/bin/env python3
49do_install_append() {
50 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
51 ${D}${prefix}/libexec/blueman-mechanism \
52 ${D}${bindir}/blueman-tray \
53 ${D}${bindir}/blueman-services \
54 ${D}${bindir}/blueman-sendto \
55 ${D}${bindir}/blueman-report \
56 ${D}${bindir}/blueman-manager \
57 ${D}${bindir}/blueman-assistant \
58 ${D}${bindir}/blueman-applet \
59 ${D}${bindir}/blueman-adapters
60}