blob: ea8bc1738eb87a21ecceb0d0c593e9fdca4a3b61 [file] [log] [blame]
Brad Bishop63ae8782019-10-09 09:56:13 -04001SUMMARY = "NVMe management command line interface"
2AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
3HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
4SECTION = "console/utils"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
Brad Bishop6a62e0e2019-10-21 08:11:42 -04007DEPENDS = "util-linux"
Brad Bishop63ae8782019-10-09 09:56:13 -04008PV .= "+git${SRCPV}"
9
10SRC_URI = "git://github.com/linux-nvme/nvme-cli.git"
11SRCREV = "977e7d4cf59c3c7f89e9c093c91f991b07292e45"
12
13S = "${WORKDIR}/git"
14
15inherit bash-completion systemd
16
17do_install() {
Brad Bishop00ab2372019-10-14 11:06:18 -040018 oe_runmake install-spec DESTDIR=${D} PREFIX=${prefix} \
Brad Bishop63ae8782019-10-09 09:56:13 -040019 UDEVDIR=${nonarch_base_libdir}/udev SYSTEMDDIR=${systemd_unitdir}
20}
21
22pkg_postinst_ontarget_${PN}() {
23 ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn
Brad Bishop6a62e0e2019-10-21 08:11:42 -040024 ${bindir}/uuidgen > ${sysconfdir}/nvme/hostid
Brad Bishop63ae8782019-10-09 09:56:13 -040025}
26
27PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
28
Brad Bishop00ab2372019-10-14 11:06:18 -040029FILES_${PN} += "${systemd_system_unitdir}"
Brad Bishope42b3e32020-01-15 22:08:42 -050030FILES_${PN}-dracut = "${nonarch_libdir}/dracut/dracut.conf.d"
Brad Bishop63ae8782019-10-09 09:56:13 -040031FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"
Brad Bishop6a62e0e2019-10-21 08:11:42 -040032
33RDEPENDS_${PN} = "util-linux-uuidgen"