blob: 29f8de8d2fd3a862d828b20db30777654d2a38da [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Minimalistic C client library for Redis"
2HOMEPAGE = "http://github.com/redis/hiredis"
3LICENSE = "BSD-3-Clause"
4SECTION = "libs"
5DEPENDS = "redis"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d84d659a35c666d23233e54503aaea51"
Brad Bishope42b3e32020-01-15 22:08:42 -05008SRCREV = "685030652cd98c5414ce554ff5b356dfe8437870"
9SRC_URI = "git://github.com/redis/hiredis;protocol=git \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010 file://0001-Makefile-remove-hardcoding-of-CC.patch"
11
12S = "${WORKDIR}/git"
13
14inherit autotools-brokensep pkgconfig
15
Brad Bishope42b3e32020-01-15 22:08:42 -050016EXTRA_OEMAKE = "PREFIX=${prefix} LIBRARY_PATH=${baselib}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18# By default INSTALL variable in Makefile is equal to 'cp -a', which preserves
19# ownership and causes host-user-contamination QA issue.
20# And PREFIX defaults to /usr/local.
21do_install_prepend() {
22 export INSTALL='cp -r'
23}