blob: ffd46da0af1b4fbdee88433a0aed4ca2ae2baf38 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A shared storage lock manager"
2DESCRIPTION = "sanlock is a lock manager built on shared storage. Hosts with access \
3to the storage can perform locking. An application running on the \
4hosts is given a small amount of space on the shared block device or \
5file, and uses sanlock for its own application-specific synchronization. \
6Internally, the sanlock daemon manages locks using two disk-based \
7lease algorithms: delta leases and paxos leases."
8HOMEPAGE = "https://pagure.io/sanlock"
9SECTION = "utils"
10
11LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
Brad Bishope42b3e32020-01-15 22:08:42 -050012LIC_FILES_CHKSUM = "file://../README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
13
14PV .= "+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
Brad Bishop8410d612019-11-25 09:40:59 -050016SRC_URI = "git://pagure.io/sanlock.git;protocol=http \
Brad Bishope42b3e32020-01-15 22:08:42 -050017 file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch;patchdir=../ \
Brad Bishop8410d612019-11-25 09:40:59 -050018 "
Brad Bishope42b3e32020-01-15 22:08:42 -050019SRCREV = "cff348800722f7dadf030ffe7494c2df714996e3"
20
21S = "${WORKDIR}/git/python"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022
23DEPENDS = "libaio util-linux"
24
Brad Bishop8410d612019-11-25 09:40:59 -050025inherit distutils3 useradd
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
27do_configure[noexec] = "1"
28
29do_compile_prepend () {
Brad Bishope42b3e32020-01-15 22:08:42 -050030 oe_runmake -C ${S}/../wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
31 oe_runmake -C ${S}/../src CMD_LDFLAGS="${LDFLAGS}" LIB_ENTIRE_LDFLAGS="${LDFLAGS}" LIB_CLIENT_LDFLAGS="${LDFLAGS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032}
33
34do_install_prepend () {
Brad Bishope42b3e32020-01-15 22:08:42 -050035 oe_runmake -C ${S}/../wdmd DESTDIR=${D} LIBDIR=${libdir} install
36 oe_runmake -C ${S}/../src DESTDIR=${D} LIBDIR=${libdir} install
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037}
Brad Bishop8410d612019-11-25 09:40:59 -050038
39SANLOCKGROUP ?= "sanlock"
40SANLOCKUSER ?= "sanlock"
41USERADD_PACKAGES = "${PN}"
42GROUPADD_PARAM_${PN} = "--system ${SANLOCKGROUP}"
43USERADD_PARAM_${PN} = "--system -g ${SANLOCKGROUP} -G disk \
44 --home-dir /run/${SANLOCKUSER} --no-create-home \
45 --shell /sbin/nologin ${SANLOCKUSER}"