blob: 4e77d6cc02e3a0be30a1f3538a1b11755279a9ad [file] [log] [blame]
Brad Bishop0f291cc2019-09-01 15:16:57 -04001DESCRIPTION = "Tiny XML Library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
7SRC_URI = "git://github.com/michaelrsweet/mxml.git"
Brad Bishope42b3e32020-01-15 22:08:42 -05008SRCREV = "e483e5fd8a33386fd46967681521bdd2da2b548f"
Brad Bishop0f291cc2019-09-01 15:16:57 -04009S = "${WORKDIR}/git"
10
11inherit autotools
12
13PACKAGECONFIG ??= "threads"
14PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
15
16# Package does not support out of tree builds.
17B = "${S}"
18
19# MXML uses autotools but it explicitly states it does not support autoheader.
20EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
21
22do_configure_prepend() {
23 # Respect optimization CFLAGS specified by OE.
24 sed -e 's/-Os -g//' -i ${S}/configure.ac
25
26 # Enable verbose compilation output. This is required for extra QA checks to work.
27 sed -e '/.SILENT:/d' -i ${S}/Makefile.in
28}
29
30do_install() {
31 # Package uses DSTROOT instread of standard DESTDIR to specify install location.
32 oe_runmake install DSTROOT=${D}
33}