Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 1 | SUMMARY = "IMA/EMV public keys" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 4 | |
| 5 | inherit features_check |
| 6 | REQUIRED_DISTRO_FEATURES = "ima" |
| 7 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | ALLOW_EMPTY:${PN} = "1" |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 9 | |
| 10 | do_install () { |
| 11 | if [ -e "${IMA_EVM_X509}" ]; then |
| 12 | install -d ${D}/${sysconfdir}/keys |
| 13 | install "${IMA_EVM_X509}" ${D}${sysconfdir}/keys/x509_evm.der |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | ln -rs ${D}${sysconfdir}/keys/x509_evm.der ${D}${sysconfdir}/keys/x509_ima.der |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 15 | fi |
| 16 | } |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 17 | do_install[file-checksums] += "${@'${IMA_EVM_X509}:%s' % os.path.exists('${IMA_EVM_X509}')}" |