blob: 2defb5ccb7a647b33d15d7fc2a2bfa3acb50afa4 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Text file viewer similar to more"
2DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3based program for viewing text files and the output from other \
4programs. Less offers many features beyond those that more does."
5HOMEPAGE = "http://www.greenwoodsoftware.com/"
6SECTION = "console/utils"
7
Andrew Geissler9aee5002022-03-30 16:27:02 +00008# (GPL-2.0-or-later (<< 418), GPL-3.0-or-later (>= 418)) | less
Andrew Geissler595f6302022-01-24 19:11:47 +00009# Including email author giving permissing to use BSD
10#
11# From: Mark Nudelman <markn@greenwoodsoftware.com>
12# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
13# Date: 12/19/11
14#
15# Hi Elizabeth,
16# Using a generic BSD license for less is fine with me.
17# Thanks,
18#
19# --Mark
20#
21
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022LICENSE = "GPL-3.0-or-later | BSD-2-Clause"
Andrew Geissler595f6302022-01-24 19:11:47 +000023LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
Patrick Williamse760df82023-05-26 11:10:49 -050024 file://LICENSE;md5=1b2446f5c8632bf63a97d7a49750e1c6 \
Andrew Geissler595f6302022-01-24 19:11:47 +000025 "
26DEPENDS = "ncurses"
27
Patrick Williamse760df82023-05-26 11:10:49 -050028SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz"
Andrew Geissler595f6302022-01-24 19:11:47 +000029
Patrick Williamse760df82023-05-26 11:10:49 -050030SRC_URI[sha256sum] = "2f201d64b828b88af36dfe6cfdba3e0819ece2e446ebe6224813209aaefed04f"
Andrew Geissler595f6302022-01-24 19:11:47 +000031
32UPSTREAM_CHECK_URI = "http://www.greenwoodsoftware.com/less/download.html"
Andrew Geissler595f6302022-01-24 19:11:47 +000033
34inherit autotools update-alternatives
35
36do_install () {
37 oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
38}
39
40ALTERNATIVE:${PN} = "less"
41ALTERNATIVE_PRIORITY = "100"