blob: 5790d00f1014ddf81da36246857522ad22b9191f [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A Linux kernel module providing user space access to Trusted Services"
2DESCRIPTION = "${SUMMARY}"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=05e355bbd617507216a836c56cf24983"
5
6inherit module
7
8SRC_URI = "git://gitlab.arm.com/linux-arm/linux-trusted-services;protocol=https;branch=main \
9 file://Makefile;subdir=git \
10 "
11S = "${WORKDIR}/git"
12
Andrew Geisslerea144b032023-01-27 16:03:57 -060013# Tag tee-v1.1.2
14SRCREV = "8a81f5d2406f146b15a705d49b256efaa5fa3ba9"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015
16COMPATIBLE_HOST = "(arm|aarch64).*-linux"
17KERNEL_MODULE_AUTOLOAD += "arm-ffa-tee"
18
19do_install:append() {
20 install -d ${D}${includedir}
21 install -m 0644 ${S}/uapi/arm_ffa_tee.h ${D}${includedir}/
22}