blob: 1e887c4bd9040e2d26ab93792ba40c02de4baf01 [file] [log] [blame]
Brad Bishop83254dc2015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop83254dc2015-10-27 17:12:45 -04008inherit obmc-phosphor-dbus-service
9inherit obmc-phosphor-systemd
10inherit setuptools
11
Brad Bishop8ffb4022016-07-13 17:56:34 -040012DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper"
Brad Bishop83254dc2015-10-27 17:12:45 -040013RDEPENDS_${PN} += " \
14 python-xml \
15 python-dbus \
16 python-pygobject \
17 "
Chris Austenb70cb7e2015-12-02 22:32:06 -060018SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishop83254dc2015-10-27 17:12:45 -040019
Brad Bishopea4022a2016-07-26 15:52:01 -040020SRCREV = "22ff24a6e668d00557ef6465f96d664fe33226f3"
Brad Bishop83254dc2015-10-27 17:12:45 -040021
22S = "${WORKDIR}/git"
Brad Bishopea4022a2016-07-26 15:52:01 -040023
24do_compile_append() {
25 oe_runmake -C libmapper
26}
27
28do_install_append() {
29 oe_runmake -C libmapper install DESTDIR=${D}
30}
31
32python populate_packages_prepend () {
33 mapperlibdir = d.getVar("libdir", True)
34 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
35}
36PACKAGES_DYNAMIC += "^libmapper.*"
37FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"