Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Name Service Switch module for Multicast DNS (zeroconf) name resolution" |
| 2 | HOMEPAGE = "http://0pointer.de/lennart/projects/nss-mdns/" |
| 3 | SECTION = "libs" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 7 | |
| 8 | DEPENDS = "avahi" |
| 9 | PR = "r7" |
| 10 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 11 | SRC_URI = "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-${PV}.tar.gz \ |
| 12 | file://0001-check-for-nss.h.patch \ |
| 13 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI[md5sum] = "03938f17646efbb50aa70ba5f99f51d7" |
| 16 | SRC_URI[sha256sum] = "1e683c2e7c3921814706d62fbbd3e9cbf493a75fa00255e0e715508d8134fa6d" |
| 17 | |
| 18 | S = "${WORKDIR}/nss-mdns-${PV}" |
| 19 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | localstatedir = "/" |
| 21 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | inherit autotools |
| 23 | |
| 24 | EXTRA_OECONF = "--libdir=${base_libdir} --disable-lynx --enable-avahi" |
| 25 | |
| 26 | # suppress warning, but don't bother with autonamer |
| 27 | LEAD_SONAME = "libnss_mdns.so" |
| 28 | DEBIANNAME_${PN} = "libnss-mdns" |
| 29 | |
| 30 | RDEPENDS_${PN} = "avahi-daemon" |
| 31 | |
| 32 | pkg_postinst_${PN} () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | sed ' |
| 34 | /^hosts:/ !b |
| 35 | /\<mdns\(4\|6\)\?\(_minimal\)\?\>/ b |
| 36 | s/\([[:blank:]]\+\)dns\>/\1mdns4_minimal [NOTFOUND=return] dns/g |
| 37 | ' -i $D${sysconfdir}/nsswitch.conf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 38 | } |
| 39 | |
| 40 | pkg_prerm_${PN} () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 41 | sed ' |
| 42 | /^hosts:/ !b |
| 43 | s/[[:blank:]]\+mdns\(4\|6\)\?\(_minimal\( \[NOTFOUND=return\]\)\?\)\?//g |
| 44 | ' -i $D${sysconfdir}/nsswitch.conf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 45 | } |