blob: fe864c49cc23ac443a2da6bc4e89f179035c9d0b [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "The CAPS Audio Plugin Suite - LADSPA plugin suite"
2HOMEPAGE = "http://quitte.de/dsp/caps.html"
3LICENSE = "GPL-3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SRC_URI = "http://quitte.de/dsp/${PN}_${PV}.tar.bz2 \
7 file://Avoid-ambiguity-in-div-invocation.patch \
8 file://0001-basic.h-Use-c99-supported-stdint-types.patch \
9 file://append_ldflags.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040010 file://0001-Do-not-use-obsolete-pow10f-function.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060012
13SRC_URI[md5sum] = "c1d634038dcb54702306c0e30cb1c626"
14SRC_URI[sha256sum] = "f746feba57af316b159f0169de5d78b4fd1064c2c0c8017cb5856b2f22e83f20"
15
16S = "${WORKDIR}/${PN}-${PV}"
17
18EXTRA_OEMAKE = " \
19 CC='${CXX}' \
20 CFLAGS='${CFLAGS} -ffast-math -funroll-loops -fPIC -DPIC' \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 ARCH='' \
Patrick Williamsddad1a12017-02-23 20:36:32 -060022"
23do_compile() {
24 oe_runmake all
25}
26
27do_install() {
28 install -Dm 0644 caps.so ${D}${libdir}/ladspa/caps.so
29}
30
31FILES_${PN} = "${libdir}/ladspa/"