blob: d4f4ee54d3d87a64e4797276b445d732ab025d54 [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001HOMEPAGE = "http://github.com/openbmc/google-ipmi-sys"
2SUMMARY = "Google Sys OEM commands"
Patrick Ventureedb61922018-09-21 14:57:58 -07003DESCRIPTION = "Google Sys OEM commands"
Patrick Venture9afb6712018-09-17 17:14:46 -07004
5inherit autotools pkgconfig
Patrick Venture9afb6712018-09-17 17:14:46 -07006inherit systemd
7inherit obmc-phosphor-ipmiprovider-symlink
8
Patrick Ventureedb61922018-09-21 14:57:58 -07009LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
11
Patrick Venture9afb6712018-09-17 17:14:46 -070012DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14DEPENDS += "phosphor-logging"
Patrick Venture9afb6712018-09-17 17:14:46 -070015DEPENDS += "phosphor-ipmi-host"
16
Patrick Venture9afb6712018-09-17 17:14:46 -070017S = "${WORKDIR}/git"
18SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
Patrick Ventureedb61922018-09-21 14:57:58 -070019SRCREV = "ef45005c2c441a89a9bd84b9b0f22ac8a2fd9b65"
Patrick Venture9afb6712018-09-17 17:14:46 -070020
21FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
22FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
24FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
25
26HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
27
28SYSTEMD_PACKAGES = "${PN}"
29SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
30
31do_install_append() {
32 install -d ${D}${systemd_system_unitdir}
33 install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
34}