Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject" |
| 2 | DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\ |
| 3 | data structures, using a DOM-like API. JSON-GLib also offers GObject \ |
| 4 | integration, providing the ability to serialize and deserialize GObject \ |
| 5 | instances to and from JSON data types." |
| 6 | HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues" |
| 8 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | LICENSE = "LGPL-2.1-only" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
| 12 | DEPENDS = "glib-2.0" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | inherit gnomebase lib_package gobject-introspection gi-docgen gettext ptest-gnome manpages upstream-version-is-even |
| 16 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 17 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 18 | GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' |
| 19 | GIDOCGEN_MESON_DISABLE_FLAG = 'disabled' |
| 20 | |
| 21 | SRC_URI += " file://run-ptest" |
| 22 | SRC_URI[archive.sha256sum] = "96ec98be7a91f6dde33636720e3da2ff6ecbb90e76ccaa49497f31a6855a490e" |
| 23 | |
| 24 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
| 25 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native" |
| 26 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false" |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |
| 29 | |
| 30 | # Currently it's not possible to disable gettext in Meson, so we need to force |
| 31 | # this back on. |
| 32 | USE_NLS:class-native = "yes" |