blob: 23ddfce6428ebfa20e2f2a231f2e1e5961eb7fad [file] [log] [blame]
Brad Bishop1fdf4aa2019-09-09 14:56:41 -04001SUMMARY = "Network scanning and manipulation tool"
2DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. It is able to forge or decode packets of a wide number of protocols, send them on the wire, capture them, match requests and replies, and much more. It can easily handle most classical tasks like scanning, tracerouting, probing, unit tests, attacks or network discovery (it can replace hping, 85% of nmap, arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very well at a lot of other specific tasks that most other tools can't handle, like sending invalid frames, injecting your own 802.11 frames, combining technics (VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
3SECTION = "security"
4LICENSE = "GPLv2"
Brad Bishop19323692019-04-05 15:28:33 -04005
Brad Bishop1fdf4aa2019-09-09 14:56:41 -04006LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9
Andrew Geissler8b139282021-03-05 15:22:30 -060010SRCREV = "95ba5b8504152a1f820bbe679ccf03668cb5118f"
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040011SRC_URI = "git://github.com/secdev/scapy.git \
12 file://run-ptest"
13
14S = "${WORKDIR}/git"
15
William A. Kennington IIIee32beb2021-06-02 12:48:35 -070016UPSTREAM_CHECK_COMMITS = "1"
17
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040018inherit setuptools3 ptest
Brad Bishop19323692019-04-05 15:28:33 -040019
Brad Bishop15ae2502019-06-18 21:44:24 -040020do_install_append() {
21 mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
22 mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3
23}
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040024
25do_install_ptest() {
26 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
27 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
28}
29
30RDEPENDS_${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
31 ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
32 ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-pycrypto"