blob: 9b1ba4f2eacc528323a1dacc9f8134a9bf439d4c [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "Userspace utilities for fs-verity"
2DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \
3on-demand integrity/authenticity verification of the contents of read-only \
4files, using a hidden Merkle tree (hash tree) associated with the file. The \
5mechanism is similar to dm-verity, but implemented at the file level rather \
6than at the block device level."
7HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html"
8SECTION = "console"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220"
11
Andrew Geisslereef63862021-01-29 15:58:13 -060012SRCREV = "a92b1a54b003879322c044adf0ae3ea3e95e7348"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050013SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "openssl"
18
Andrew Geisslereef63862021-01-29 15:58:13 -060019EXTRA_OEMAKE_append = "PREFIX=${prefix} USE_SHARED_LIB=1"
20# We want to statically link the binary to libfsverity on native Windows
21EXTRA_OEMAKE_remove_mingw32_class-nativesdk = "USE_SHARED_LIB=1"
22EXTRA_OEMAKE_remove_mingw32_class-native = "USE_SHARED_LIB=1"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050023
24do_install() {
25 oe_runmake install DESTDIR=${D}
26}
27
28PACKAGES =+ "libfsverity"
29FILES_libfsverity = "${libdir}/libfsverity*${SOLIBS}"
30
31BBCLASSEXTEND = "native nativesdk"