blob: 8b267c9cba44fd2d700c49a30912b651b234756c [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Meta-python ptest packagegroups"
Brad Bishop19323692019-04-05 15:28:33 -04002
3inherit packagegroup
4
5PROVIDES = "${PACKAGES}"
6PACKAGES = ' \
Brad Bishop19323692019-04-05 15:28:33 -04007 packagegroup-meta-python3 \
8'
9
Andrew Geisslereef63862021-01-29 15:58:13 -060010# Note that python3-cvxopt requires Fortran support. To enable this,
11# add the following to your local.conf:
12# FORTRAN_forcevariable = ",fortran"
Brad Bishop19323692019-04-05 15:28:33 -040013RDEPENDS_packagegroup-meta-python3 = "\
Andrew Geisslereef63862021-01-29 15:58:13 -060014 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
15 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
16 gyp \
Andrew Geisslerd688a012020-09-18 13:36:00 -050017 pamela \
18 pyrtm \
Andrew Geisslereef63862021-01-29 15:58:13 -060019 python3-absl \
Andrew Geisslerd688a012020-09-18 13:36:00 -050020 python3-aenum \
Andrew Geisslerd688a012020-09-18 13:36:00 -050021 python3-aiofiles \
Andrew Geisslerd688a012020-09-18 13:36:00 -050022 python3-aiohttp \
Andrew Geisslereef63862021-01-29 15:58:13 -060023 python3-aiohttp-jinja2 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050024 python3-alembic \
25 python3-ansi2html \
26 python3-ansicolors \
Andrew Geisslereef63862021-01-29 15:58:13 -060027 python3-anyjson \
Andrew Geisslerd688a012020-09-18 13:36:00 -050028 python3-appdirs \
29 python3-apply-defaults \
Andrew Geisslereef63862021-01-29 15:58:13 -060030 python3-argcomplete \
31 python3-argexec \
Andrew Geisslerd688a012020-09-18 13:36:00 -050032 python3-argh \
Andrew Geisslerd688a012020-09-18 13:36:00 -050033 python3-arpeggio \
Andrew Geisslereef63862021-01-29 15:58:13 -060034 python3-asciitree \
Andrew Geisslerd688a012020-09-18 13:36:00 -050035 python3-asn1crypto \
Andrew Geisslereef63862021-01-29 15:58:13 -060036 python3-astor \
37 python3-astroid \
38 python3-asttokens \
Andrew Geisslerd688a012020-09-18 13:36:00 -050039 python3-async-timeout \
Andrew Geisslerd688a012020-09-18 13:36:00 -050040 python3-attr \
Andrew Geisslerd688a012020-09-18 13:36:00 -050041 python3-autobahn \
Andrew Geisslerd688a012020-09-18 13:36:00 -050042 python3-automat \
Andrew Geisslerd688a012020-09-18 13:36:00 -050043 python3-aws-iot-device-sdk-python \
Andrew Geisslereef63862021-01-29 15:58:13 -060044 python3-babel \
Andrew Geisslerd688a012020-09-18 13:36:00 -050045 python3-backcall \
46 python3-backports-functools-lru-cache \
Andrew Geisslereef63862021-01-29 15:58:13 -060047 python3-bandit \
48 python3-bcrypt \
Andrew Geisslerd688a012020-09-18 13:36:00 -050049 python3-beautifulsoup4 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050050 python3-behave \
Andrew Geisslereef63862021-01-29 15:58:13 -060051 python3-betamax \
Andrew Geisslerd688a012020-09-18 13:36:00 -050052 python3-bitarray \
53 python3-bitstring \
54 python3-bitstruct \
Andrew Geisslereef63862021-01-29 15:58:13 -060055 python3-blinker \
56 python3-blivet \
Andrew Geisslerd688a012020-09-18 13:36:00 -050057 python3-booleanpy \
Andrew Geisslereef63862021-01-29 15:58:13 -060058 python3-cachecontrol \
Andrew Geisslerd688a012020-09-18 13:36:00 -050059 python3-cachetools \
60 python3-can \
61 python3-cantools \
62 python3-cassandra-driver \
63 python3-cbor2 \
Andrew Geisslereef63862021-01-29 15:58:13 -060064 python3-cerberus \
Andrew Geisslerd688a012020-09-18 13:36:00 -050065 python3-certifi \
Andrew Geisslereef63862021-01-29 15:58:13 -060066 python3-cffi \
67 python3-chardet \
Andrew Geisslerd688a012020-09-18 13:36:00 -050068 python3-cheetah \
69 python3-click \
Andrew Geisslereef63862021-01-29 15:58:13 -060070 python3-click-repl \
71 python3-click-spinner \
72 python3-cmd2 \
73 python3-colorama \
Andrew Geisslerd688a012020-09-18 13:36:00 -050074 python3-coloredlogs \
75 python3-colorlog \
Andrew Geisslereef63862021-01-29 15:58:13 -060076 python3-configargparse \
77 python3-configobj \
78 python3-configparser \
Andrew Geisslerd688a012020-09-18 13:36:00 -050079 python3-configshell-fb \
80 python3-constantly \
81 python3-contextlib2 \
Andrew Geisslereef63862021-01-29 15:58:13 -060082 python3-coverage \
Andrew Geisslerd688a012020-09-18 13:36:00 -050083 python3-cppy \
Andrew Geisslereef63862021-01-29 15:58:13 -060084 python3-crcmod \
85 python3-croniter \
86 python3-cryptography \
87 python3-cryptography-vectors \
88 python3-cson \
89 python3-custom-inherit \
90 python3-cvxopt \
91 python3-cycler \
92 python3-dateparser \
Andrew Geisslerd688a012020-09-18 13:36:00 -050093 python3-dateutil \
Andrew Geisslereef63862021-01-29 15:58:13 -060094 python3-dbus-next \
95 python3-dbussy \
96 python3-decorator \
97 python3-defusedxml \
98 python3-dill \
99 python3-diskcache \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500100 python3-distro \
Andrew Geisslereef63862021-01-29 15:58:13 -0600101 python3-django \
102 python3-django-south \
103 python3-djangorestframework \
104 python3-dnspython \
105 python3-docopt \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500106 python3-dominate \
Andrew Geisslereef63862021-01-29 15:58:13 -0600107 python3-dt-schema \
108 python3-dynamic-dispatch \
109 python3-ecdsa \
110 python3-editor \
111 python3-engineio \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500112 python3-et-xmlfile \
Andrew Geisslereef63862021-01-29 15:58:13 -0600113 python3-evdev \
114 python3-fann2 \
115 python3-fasteners \
116 python3-fastnumbers \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500117 python3-feedformatter \
Andrew Geisslereef63862021-01-29 15:58:13 -0600118 python3-flask \
119 python3-flask-babel \
120 python3-flask-bootstrap \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500121 python3-flask-jsonpify \
122 python3-flask-jwt \
Andrew Geisslereef63862021-01-29 15:58:13 -0600123 python3-flask-login \
124 python3-flask-mail \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500125 python3-flask-migrate \
Andrew Geisslereef63862021-01-29 15:58:13 -0600126 python3-flask-nav \
127 python3-flask-pymongo \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500128 python3-flask-restful \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500129 python3-flask-script \
130 python3-flask-sijax \
Andrew Geisslereef63862021-01-29 15:58:13 -0600131 python3-flask-socketio \
132 python3-flask-sqlalchemy \
133 python3-flask-uploads \
134 python3-flask-user \
135 python3-flask-versioned \
136 python3-flask-wtf \
137 python3-flask-xstatic \
138 python3-future \
139 python3-gast \
140 python3-geojson \
141 python3-gevent \
142 python3-gmpy2 \
143 python3-gmqtt \
144 python3-gnupg \
145 python3-google-api-python-client \
146 python3-graphviz \
147 python3-greenlet \
148 python3-greenstalk \
149 python3-grpcio \
150 python3-grpcio-tools \
151 python3-gsocketpool \
152 python3-gunicorn \
153 python3-h2 \
154 python3-h5py \
155 python3-haversine \
156 python3-hexdump \
157 python3-hpack \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500158 python3-html2text \
159 python3-html5lib \
Andrew Geisslereef63862021-01-29 15:58:13 -0600160 python3-httplib2 \
161 python3-huey \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500162 python3-humanfriendly \
Andrew Geisslereef63862021-01-29 15:58:13 -0600163 python3-humanize \
164 python3-hyperframe \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500165 python3-hyperlink \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500166 python3-icu \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500167 python3-idna \
Andrew Geisslereef63862021-01-29 15:58:13 -0600168 python3-idna \
169 python3-idna-ssl \
170 python3-imageio \
171 python3-incremental \
172 python3-inflection \
173 python3-intervals \
174 python3-ipaddress \
175 python3-ipy \
176 python3-ipython \
177 python3-ipython-genutils \
178 python3-iso3166 \
179 python3-iso8601 \
180 python3-isodate \
181 python3-isort \
182 python3-itsdangerous \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500183 python3-javaobj-py3 \
Andrew Geisslereef63862021-01-29 15:58:13 -0600184 python3-jdatetime \
185 python3-jdcal \
186 python3-jedi \
187 python3-jsmin \
188 python3-jsonpatch \
189 python3-jsonpath-rw \
190 python3-jsonpointer \
191 python3-jsonref \
192 python3-jsonrpcserver \
193 python3-jsonschema \
194 python3-jstyleson \
195 python3-kconfiglib \
196 python3-keras-applications \
197 python3-keras-preprocessing \
198 python3-kiwisolver \
199 python3-langtable \
200 python3-lazy-object-proxy \
201 python3-libconf \
202 python3-license-expression \
203 python3-lockfile \
204 python3-lorem \
205 python3-lrparsing \
206 python3-luma-core \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500207 python3-luma-oled \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500208 python3-lxml \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500209 python3-lz4 \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500210 python3-m2crypto \
Andrew Geisslereef63862021-01-29 15:58:13 -0600211 python3-markdown \
212 python3-markupsafe \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500213 python3-matplotlib \
Andrew Geisslereef63862021-01-29 15:58:13 -0600214 python3-mccabe \
215 python3-meh \
216 python3-meld3 \
217 python3-mock \
218 python3-monotonic \
219 python3-mpmath \
220 python3-msgpack \
221 python3-msk \
222 python3-msm \
223 python3-multidict \
224 python3-mypy \
225 python3-mypy-extensions \
226 python3-natsort \
227 python3-ndg-httpsclient \
228 python3-netaddr \
229 python3-netifaces \
230 python3-networkx \
231 python3-nmap \
232 python3-nocasedict \
233 python3-nocaselist \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500234 python3-ntplib \
Andrew Geisslereef63862021-01-29 15:58:13 -0600235 python3-oauthlib \
236 python3-obd \
237 python3-openpyxl \
238 python3-ordered-set \
239 python3-padaos \
240 python3-padatious \
241 python3-paho-mqtt \
242 python3-pako \
243 python3-pandas \
244 python3-parallax \
245 python3-paramiko \
246 python3-parse \
247 python3-parse-type \
248 python3-parso \
249 python3-passlib \
250 python3-pathtools3 \
251 python3-pep8 \
252 python3-periphery \
253 python3-petact \
254 python3-pexpect \
255 python3-pickleshare \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500256 python3-pid \
Andrew Geisslereef63862021-01-29 15:58:13 -0600257 python3-pika \
258 python3-pillow \
259 python3-pint \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500260 python3-pkgconfig \
Andrew Geisslereef63862021-01-29 15:58:13 -0600261 python3-ply \
262 python3-pocketsphinx \
263 python3-polyline \
264 python3-prctl \
265 python3-precise-runner \
266 python3-pretend \
267 python3-prettytable \
268 python3-priority \
269 python3-progress \
270 python3-prompt-toolkit \
271 python3-protobuf \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500272 python3-psutil \
Andrew Geisslereef63862021-01-29 15:58:13 -0600273 python3-ptyprocess \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500274 python3-pulsectl \
275 python3-py-ubjson \
276 python3-pyalsaaudio \
Andrew Geisslereef63862021-01-29 15:58:13 -0600277 python3-pyasn1 \
278 python3-pyasn1-modules \
279 python3-pyatspi \
280 python3-pyaudio \
281 python3-pybind11 \
282 python3-pybind11-json \
283 python3-pybluez \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500284 python3-pychromecast \
Andrew Geisslereef63862021-01-29 15:58:13 -0600285 python3-pycodestyle \
286 python3-pyconnman \
287 python3-pycparser \
288 python3-pycrypto \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500289 python3-pycurl \
Andrew Geisslereef63862021-01-29 15:58:13 -0600290 python3-pydbus \
291 python3-pydicti \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500292 python3-pyephem \
Andrew Geisslereef63862021-01-29 15:58:13 -0600293 python3-pyexpect \
294 python3-pyfirmata \
295 python3-pyflakes \
296 python3-pyhamcrest \
297 python3-pyiface \
298 python3-pyinotify \
299 python3-pyjks \
300 python3-pyjwt \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500301 python3-pykickstart \
Andrew Geisslereef63862021-01-29 15:58:13 -0600302 python3-pykwalify \
303 python3-pylint \
304 python3-pylyrics \
305 python3-pymisp \
306 python3-pymongo \
307 python3-pymysql \
308 python3-pynacl \
309 python3-pynetlinux \
310 python3-pyopenssl \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500311 python3-pyparted \
Andrew Geisslereef63862021-01-29 15:58:13 -0600312 python3-pyperclip \
313 python3-pyperf \
314 python3-pyrad \
315 python3-pyro4 \
316 python3-pyroute2 \
317 python3-pyrsistent \
318 python3-pyscaffold \
319 python3-pyserial \
320 python3-pysocks \
321 python3-pystache \
322 python3-pystemd \
323 python3-pytest-asyncio \
324 python3-pytest-helpers-namespace \
325 python3-pytest-html \
326 python3-pytest-metadata \
327 python3-pytest-runner \
328 python3-pytest-tempdir \
329 python3-pytest-timeout \
330 python3-python-vlc \
331 python3-pytoml \
332 python3-pytun \
333 python3-pytz \
334 python3-pyudev \
335 python3-pyusb \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500336 python3-pywbem \
337 python3-pywbemtools \
Andrew Geisslereef63862021-01-29 15:58:13 -0600338 python3-pyyaml \
339 python3-pyzmq \
340 python3-qrcode \
341 python3-raven \
342 python3-rdflib \
343 python3-redis \
344 python3-regex \
345 python3-requests \
346 python3-requests-file \
347 python3-requests-ftp \
348 python3-requests-futures \
349 python3-requests-oauthlib \
350 python3-requests-toolbelt \
351 python3-rfc3339-validator \
352 python3-rfc3986-validator \
353 python3-rfc3987 \
354 python3-robotframework \
355 python3-robotframework-seriallibrary \
356 python3-rsa \
357 python3-ruamel-yaml \
358 python3-scapy \
359 python3-scrypt \
360 python3-sdnotify \
361 python3-semver \
362 python3-send2trash \
363 python3-sentry-sdk \
364 python3-serpent \
365 python3-sh \
366 python3-sijax \
367 python3-simpleeval \
368 python3-simplejson \
369 python3-slip-dbus \
370 python3-smbus \
371 python3-smbus2 \
372 python3-smpplib \
373 python3-snappy \
374 python3-socketio \
375 python3-soupsieve \
376 python3-speaklater \
377 python3-speedtest-cli \
378 python3-spidev \
379 python3-spidev \
380 python3-sqlalchemy \
381 python3-sqlparse \
382 python3-sqlsoup \
383 python3-stevedore \
384 python3-strict-rfc3339 \
385 python3-supervisor \
386 python3-sympy \
387 python3-tabulate \
388 python3-term \
389 python3-termcolor \
390 python3-test-generator \
391 python3-textparser \
392 python3-texttable \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500393 python3-thrift \
Andrew Geisslereef63862021-01-29 15:58:13 -0600394 python3-tinyrecord \
395 python3-tornado \
396 python3-tqdm \
397 python3-trafaret \
398 python3-trafaret-config \
399 python3-traitlets \
400 python3-transitions \
401 python3-twine \
402 python3-twisted \
403 python3-twitter \
404 python3-twofish \
405 python3-txaio \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500406 python3-txws \
Andrew Geisslereef63862021-01-29 15:58:13 -0600407 python3-typed-ast \
408 python3-typeguard \
409 python3-typing-extensions \
410 python3-tzlocal \
411 python3-u-msgpack-python \
412 python3-ujson \
413 python3-unidiff \
414 python3-uritemplate \
415 python3-urllib3 \
416 python3-vcversioner \
417 python3-versiontools \
418 python3-visitor \
419 python3-waitress \
420 python3-watchdog \
421 python3-webcolors \
422 python3-webencodings \
423 python3-websocket-client \
424 python3-websockets \
425 python3-werkzeug \
426 python3-werkzeug \
427 python3-wheel \
428 python3-whoosh \
429 python3-wrapt \
430 python3-wtforms \
431 python3-xlrd \
432 python3-xlsxwriter \
433 python3-xmlrunner \
434 python3-xmltodict \
435 python3-xmodem \
436 python3-xstatic \
437 python3-xstatic-font-awesome \
438 python3-xxhash \
439 python3-yamlloader \
440 python3-yappi \
441 python3-yarl \
442 python3-zopeinterface \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500443 telepathy-python3 \
Brad Bishop19323692019-04-05 15:28:33 -0400444"
445
Brad Bishop19323692019-04-05 15:28:33 -0400446RDEPENDS_packagegroup-meta-python3-ptest = "\
Andrew Geisslerd688a012020-09-18 13:36:00 -0500447 python3-cryptography-ptest \
Andrew Geisslera2681d92020-10-16 10:17:07 -0500448 python3-jinja2-ptest \
449 python3-markupsafe-ptest \
Andrew Geisslereef63862021-01-29 15:58:13 -0600450 python3-ansicolors-ptest \
451 python3-anyjson-ptest \
452 python3-appdirs-ptest \
453 python3-backports-functools-lru-cache-ptest \
454 python3-bcrypt-ptest \
455 python3-betamax-ptest \
456 python3-blinker-ptest \
457 python3-cachetools-ptest \
458 python3-cbor2-ptest \
459 python3-click-ptest \
460 python3-cryptography-ptest \
461 python3-dnspython-ptest \
462 python3-dominate-ptest \
463 python3-geojson-ptest \
464 python3-gunicorn-ptest \
465 python3-html2text-ptest \
466 python3-inflection-ptest \
467 python3-intervals-ptest \
468 python3-ipy-ptest \
469 python3-iso3166-ptest \
470 python3-jdcal-ptest \
471 python3-jinja2-ptest \
472 python3-jsmin-ptest \
473 python3-jsonpointer-ptest \
474 python3-license-expression-ptest \
475 python3-markupsafe-ptest \
476 python3-msgpack-ptest \
477 python3-multidict-ptest \
478 python3-ordered-set-ptest \
479 python3-parse-ptest \
480 python3-parse-type-ptest \
481 python3-pint-ptest \
482 python3-polyline-ptest \
483 python3-precise-runner-ptest \
484 python3-prettytable-ptest \
485 python3-ptyprocess-ptest \
486 python3-pyasn1-modules-ptest \
487 python3-pyroute2-ptest \
488 python3-pyserial-ptest \
489 python3-pytoml-ptest \
490 python3-pytz-ptest \
491 python3-requests-file-ptest \
492 python3-requests-toolbelt-ptest \
493 python3-scrypt-ptest \
494 python3-semver-ptest \
495 python3-serpent-ptest \
496 python3-simpleeval-ptest \
497 python3-smpplib-ptest \
498 python3-soupsieve-ptest \
499 python3-sqlparse-ptest \
500 python3-test-generator-ptest \
501 python3-typeguard-ptest \
502 python3-ujson-ptest \
503 python3-u-msgpack-python-ptest \
504 python3-unidiff-ptest \
505 python3-uritemplate-ptest \
506 python3-webcolors-ptest \
507 python3-whoosh-ptest \
508 python3-xlrd-ptest \
509 python3-xmltodict-ptest \
510 python3-xxhash-ptest \
511 python3-yappi-ptest \
512 python3-yarl-ptest \
513 python3-pyasn1-ptest \
Andrew Geisslera2681d92020-10-16 10:17:07 -0500514"
Brad Bishop19323692019-04-05 15:28:33 -0400515
516EXCLUDE_FROM_WORLD = "1"