blob: d79206fe68c25111dd923f950f0f5d25e10044ee [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05005LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geisslereef63862021-01-29 15:58:13 -06007SRC_URI[sha256sum] = "c615a9e9e378a7383b756b7e7a73c38b22aeb8967a8bfbffd4741f7ffd043c4d"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
Andrew Geissler2ee498a2020-05-29 15:52:06 -050015DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
16
Andrew Geissler82c905d2020-04-13 13:39:40 -050017RDEPENDS_${PN} += "\
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-numbers \
20"
21
22RDEPENDS_${PN}-ptest += " \
23 ${PYTHON_PN}-pytz \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
30
31BBCLASSEXTEND = "native nativesdk"