blob: aa8db80c10619395c9cb5636d73f5ad2ad5d2547 [file] [log] [blame]
Patrick Venture998ff012018-03-09 15:37:45 -08001SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
Patrick Ventureffad0482018-09-29 09:19:22 -07003HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
Patrick Venture998ff012018-03-09 15:37:45 -08004PR = "r1"
Patrick Ventureffad0482018-09-29 09:19:22 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture998ff012018-03-09 15:37:45 -08008
Patrick Ventured4c82372019-07-03 10:32:22 -07009inherit autotools pkgconfig
Patrick Venture998ff012018-03-09 15:37:45 -080010
Patrick Venture998ff012018-03-09 15:37:45 -080011inherit obmc-phosphor-ipmiprovider-symlink
Vijay Khemka09ad25b2019-06-20 14:37:11 -070012inherit systemd
Patrick Venture998ff012018-03-09 15:37:45 -080013
Patrick Ventureffad0482018-09-29 09:19:22 -070014S = "${WORKDIR}/git"
15SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
Andrew Geisslere8076e62020-08-04 18:21:09 +000016SRCREV = "1277543ac599de45d15db99d15bd0e89d3653c9b"
Patrick Ventureffad0482018-09-29 09:19:22 -070017
Patrick Venture998ff012018-03-09 15:37:45 -080018# Each platform will need a service file that starts
19# at an appropriate time per system. For instance, if
20# your system relies on passive dbus for fans or other
21# sensors then it may be prudent to wait for all of them.
22
23DEPENDS += "autoconf-archive-native"
Patrick Venture998ff012018-03-09 15:37:45 -080024DEPENDS += "sdbusplus"
Brad Bishop44f3cce2019-03-22 23:41:42 -040025DEPENDS += "phosphor-dbus-interfaces"
Patrick Venture998ff012018-03-09 15:37:45 -080026DEPENDS += "phosphor-logging"
27DEPENDS += "libevdev"
Patrick Venture4686bb52019-02-12 08:59:31 -080028DEPENDS += "nlohmann-json"
Patrick Venture0647c292019-03-11 08:45:12 -070029DEPENDS += "cli11"
Andrew Geissler3f2554c2019-04-15 14:22:02 +000030DEPENDS += "boost"
Patrick Venture998ff012018-03-09 15:37:45 -080031
Patrick Venture998ff012018-03-09 15:37:45 -080032# We depend on this to be built first so we can build our providers.
33DEPENDS += "phosphor-ipmi-host"
34
Vijay Khemka09ad25b2019-06-20 14:37:11 -070035SERVICE_FILE = "phosphor-pid-control.service"
36SYSTEMD_PACKAGES = "${PN}"
37SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
38
39EXTRA_OECONF = " \
40 SYSTEMD_TARGET="multi-user.target" \
41 "
42
Andrew Geissler00506842019-03-29 16:11:53 +000043FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
Patrick Venture998ff012018-03-09 15:37:45 -080044
Patrick Venture26f8c6c2018-07-27 07:27:01 -070045# The following installs the OEM IPMI handler for the fan controls.
46FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
47FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
48FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
49FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture998ff012018-03-09 15:37:45 -080050
Patrick Venture26f8c6c2018-07-27 07:27:01 -070051HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"