blob: 545224a99e322435c15d7eff2bf9ad34788dfb45 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "library to access web services that claim to be "RESTful""
Andrew Geisslereafcbb82020-06-05 17:59:17 -05002HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
Brad Bishope42b3e32020-01-15 22:08:42 -05003LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
5
6GNOMEBASEBUILDCLASS = "autotools"
7
8DEPENDS = " \
9 libxml2-native \
10 glib-2.0-native \
11 glib-2.0 \
12 libsoup-2.4 \
13"
14
15inherit gnomebase gobject-introspection gtk-doc vala
16
Andrew Geisslereff27472021-10-29 15:35:00 -050017PV .= "+git${SRCPV}"
18SRCREV = "7b46065dea860ef09861f4d70124728b8270c8b7"
19SRC_URI = "git://gitlab.gnome.org/GNOME/librest;protocol=https;branch=master \
20 file://0001-Use-GUri-instead-of-SoupURI.patch \
21 file://0002-Port-to-libsoup3.patch \
22"
23S = "${WORKDIR}/git"
Brad Bishope42b3e32020-01-15 22:08:42 -050024
Patrick Williams213cb262021-08-07 19:21:33 -050025do_configure:prepend() {
Brad Bishope42b3e32020-01-15 22:08:42 -050026 # rest expects introspection.m4 at custom location (see aclocal.m4).
27 cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030do_compile:prepend() {
Brad Bishope42b3e32020-01-15 22:08:42 -050031 export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
32}
33