blob: 79aaad9d8556e7ca890f709869a3e3ebca2888ef [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Open-source software for volunteer computing"
5DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \
6source software platform which supports distributed computing, primarily in \
7the form of volunteer computing and desktop Grid computing. It is well \
8suited for problems which are often described as trivially parallel. BOINC \
9is the underlying software used by projects such as SETI@home, Einstein@Home, \
10ClimatePrediciton.net, the World Community Grid, and many other distributed \
11computing projects. \
12This package installs the BOINC client software, which will allow your \
13computer to participate in one or more BOINC projects, using your spare \
14computer time to search for cures for diseases, model protein folding, study \
15global warming, discover sources of gravitational waves, and many other types \
16of scientific and mathematical research."
17
18HOMEPAGE = "http://boinc.berkeley.edu/"
Andrew Geisslereff27472021-10-29 15:35:00 -050019PNBLACKLIST[boinc-client] ?= "Needs porting to openssl 3.x"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020LICENSE = "LGPLv2+ & GPLv3"
21LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
22 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6"
23SECTION = "applications"
24DEPENDS = "curl \
25 jpeg \
26 openssl \
27 sqlite3 \
28 virtual/libgl \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \
31 nettle \
32"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060033SRCREV = "df0239e6f074207798a8ecf1358a74545dda9132"
34BRANCH = "client_release/7/7.16"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \
36 file://boinc-AM_CONDITIONAL.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037 file://gtk-configure.patch \
38"
39
Brad Bishop8410d612019-11-25 09:40:59 -050040inherit gettext autotools pkgconfig features_check systemd
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041
42REQUIRED_DISTRO_FEATURES += "opengl"
43
44S = "${WORKDIR}/git"
45
46EXTRA_OECONF += "\
47 --enable-libraries \
48 --enable-unicode \
49 --enable-shared \
50 --enable-dynamic-client-linkage \
51 --enable-client \
52 --disable-server \
53 --disable-static \
54 --disable-manager \
55 --with-ssl=${STAGING_EXECPREFIXDIR} \
56 --without-wxdir \
57 --without-x \
58 --with-boinc-platform=${TARGET_SYS} \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060059 ac_cv_c_undeclared_builtin_options='none' \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060"
61export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
62
Patrick Williams213cb262021-08-07 19:21:33 -050063do_configure:prepend () {
Andrew Geisslerac970dd2021-02-12 15:32:45 -060064 if [ "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0" ]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080065 then
66 export GTK2_CFLAGS=""
67 export GTK2_LIBS=""
68 fi
69}
70
Patrick Williams213cb262021-08-07 19:21:33 -050071do_compile:prepend () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080072 # Disable rpaths
73 sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool
74 sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool
75 sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool
76}
Andrew Geissler82c905d2020-04-13 13:39:40 -050077
Patrick Williams213cb262021-08-07 19:21:33 -050078do_install:append() {
Brad Bishope42b3e32020-01-15 22:08:42 -050079 if [ -e ${D}${nonarch_libdir}/systemd/system/boinc-client.service ]; then
Andrew Geissler82c905d2020-04-13 13:39:40 -050080 install -d ${D}${systemd_system_unitdir}
Brad Bishope42b3e32020-01-15 22:08:42 -050081 mv \
82 ${D}${nonarch_libdir}/systemd/system/boinc-client.service \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080083 ${D}${systemd_system_unitdir}/boinc-client.service
Brad Bishope42b3e32020-01-15 22:08:42 -050084 rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd/system \
Andrew Geissler82c905d2020-04-13 13:39:40 -050085 ${D}${nonarch_libdir}/systemd \
86 ${D}${nonarch_libdir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087 fi
88}
89
Patrick Williams213cb262021-08-07 19:21:33 -050090SYSTEMD_SERVICE:${PN} = "boinc-client.service"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080091
Patrick Williams213cb262021-08-07 19:21:33 -050092FILES:${PN} += "${libdir}/systemd"