blob: 563a0ee00ae44559430fc35133a705aab20f9f57 [file] [log] [blame]
Brad Bishop868407c2019-11-04 13:24:47 -05001require ${BPN}.inc
2
Andrew Geisslereff27472021-10-29 15:35:00 -05003inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd pkgconfig
Brad Bishop868407c2019-11-04 13:24:47 -05004
5# polkit and gobject-introspection are mandatory and cannot be configured
6REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
Patrick Williams213cb262021-08-07 19:21:33 -05007UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
Brad Bishop868407c2019-11-04 13:24:47 -05008
9DEPENDS += " \
10 ${BPN}-native \
11 glib-2.0 \
12 lcms \
13 sqlite3 \
14 libgusb \
15 libgudev \
16 polkit \
17"
18
19SRC_URI += " \
20 file://0001-Run-native-cd_idt8-cd_create_profile.patch \
21"
22
23EXTRA_OEMESON = " \
24 -Dman=false \
25 -Ddocs=false \
26"
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
29PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
30
Patrick Williams213cb262021-08-07 19:21:33 -050031SYSTEMD_SERVICE:${PN} = "colord.service"
Brad Bishop868407c2019-11-04 13:24:47 -050032
Patrick Williams213cb262021-08-07 19:21:33 -050033FILES:${PN} += " \
Brad Bishop868407c2019-11-04 13:24:47 -050034 ${datadir}/dbus-1 \
35 ${datadir}/polkit-1 \
36 ${datadir}/glib-2.0 \
37 ${datadir}/color \
38 ${systemd_user_unitdir} \
Andrew Geissler8fc454f2020-12-11 16:27:59 -060039 ${nonarch_libdir}/tmpfiles.d \
Brad Bishop868407c2019-11-04 13:24:47 -050040 ${libdir}/colord-plugins \
41 ${libdir}/colord-sensors \
42"
43
44USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050045USERADD_PARAM:${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"