blob: c726bef3b59279aeaed567a4ab040f6ac5874065 [file] [log] [blame]
Andrew Geisslere34f8962021-04-15 15:53:51 -05001DESCRIPTION = "Parallelism library for C++ - runtime files \
2 TBB is a library that helps you leverage multi-core processor \
3 performance without having to be a threading expert. It represents a \
4 higher-level, task-based parallelism that abstracts platform details \
5 and threading mechanism for performance and scalability."
6HOMEPAGE = "https://software.intel.com/en-us/tbb"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327"
9
Patrick Williams213cb262021-08-07 19:21:33 -050010DEPENDS:append:libc-musl = " libucontext"
Andrew Geisslere34f8962021-04-15 15:53:51 -050011
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050012PE = "1"
13
Andrew Geisslere34f8962021-04-15 15:53:51 -050014BRANCH = "onetbb_2021"
15SRCREV = "2dba2072869a189b9fdab3ffa431d3ea49059a19"
16SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \
17 file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \
18 file://GLIBC-PREREQ-is-not-defined-on-musl.patch \
19 file://0001-CMakeLists.txt-exclude-riscv64-riscv32.patch \
20 file://0001-Disable-use-of-_tpause-instruction.patch \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070021 file://0001-set_my_tls_end_of_input-Use-an-arbitrary-but-valid-p.patch \
Andrew Geissler69721092021-07-23 12:57:00 -040022 file://0001-arena-Remove-dead-code.patch \
Andrew Geisslere34f8962021-04-15 15:53:51 -050023"
24
25S = "${WORKDIR}/git"
26
27inherit cmake
28
29# test build fails, error: 'mallinfo mallinfo()' is deprecated
30EXTRA_OECMAKE += " \
31 -DTBB_TEST=OFF \
32 -DCMAKE_BUILD_TYPE=Release \
33 "
34
35
36# fails with thumb enabled:
37# | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp
38# | {standard input}: Assembler messages:
39# | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]'
40# ...
41# | make[1]: *** [concurrent_queue.o] Error 1
42ARM_INSTRUCTION_SET = "arm"
43
44ASNEEDED = ""
45
Patrick Williams213cb262021-08-07 19:21:33 -050046LDFLAGS:append:mips = " -latomic"
47LDFLAGS:append:mipsel = " -latomic"
Andrew Geisslereff27472021-10-29 15:35:00 -050048LDFLAGS:append:riscv32:toolchain-clang = " -latomic"
Andrew Geisslere34f8962021-04-15 15:53:51 -050049
Patrick Williams213cb262021-08-07 19:21:33 -050050LDFLAGS:append:libc-musl = " -lucontext"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050051
52# The latest version of oneTBB does not support PPC
Patrick Williams213cb262021-08-07 19:21:33 -050053COMPATIBLE_MACHINE:powerpc = "(!.*ppc).*"