blob: acb4b4ac20c918d1a7fab223bd5dbefeff88ca69 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e581798a7b985311f29fa3e163ea27ae"
5
6SRC_URI[sha256sum] = "8e7ebaf62e19c2feb097ffb7c94deb0f0c9fab52590784c8cd679d30ab009162"
7
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
12inherit pypi ptest setuptools3
13
14RDEPENDS:${PN} = "\
15 ${PYTHON_PN}-multidict \
16 ${PYTHON_PN}-idna \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}