blob: c5a153ab0cde68557a4f672d291eb3f4fc305f65 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003HOMEPAGE = "https://sourceforge.net/projects/gptfdisk/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8DEPENDS = "util-linux"
9
Andrew Geissler4b740dc2020-05-05 08:54:39 -050010SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
11 file://0001-gptcurses-correctly-include-curses.h.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050012 file://0001-gptcurses-correct-ncurses-6.3-errors.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050013 "
Andrew Geissler09036742021-06-25 14:25:14 -050014SRC_URI[sha256sum] = "95d19856f004dabc4b8c342b2612e8d0a9eebdd52004297188369f152e9dc6df"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
17UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
18
19EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}"
20
21PACKAGECONFIG ??= "ncurses popt"
22PACKAGECONFIG[ncurses] = "cgdisk,,ncurses"
23PACKAGECONFIG[popt] = "sgdisk,,popt"
24
25do_install() {
26 install -d ${D}${sbindir}
27 for f in cgdisk sgdisk; do
28 if [ -x $f ]; then
29 install -m 0755 $f ${D}${sbindir}
30 fi
31 done
32 install -m 0755 gdisk ${D}${sbindir}
33 install -m 0755 fixparts ${D}${sbindir}
34}
35
36BBCLASSEXTEND = "native nativesdk"