blob: 0d8fdf63733099b6bc0a2797a7714cd445f59dac [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
7
8SRC_URI[sha256sum] = "131b36680866a76e6781d13f101efb86cf674ebb9762eb70d3082b6f29889e89"
9
10DEPENDS = "python3-setuptools-scm-native"
11
12inherit update-alternatives pypi setuptools3
13
14RDEPENDS:${PN}:class-target += " \
15 ${PYTHON_PN}-atomicwrites \
16 ${PYTHON_PN}-attrs \
17 ${PYTHON_PN}-debugger \
18 ${PYTHON_PN}-doctest \
19 ${PYTHON_PN}-importlib-metadata \
20 ${PYTHON_PN}-iniconfig \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-more-itertools \
23 ${PYTHON_PN}-packaging \
24 ${PYTHON_PN}-pathlib2 \
25 ${PYTHON_PN}-pluggy \
26 ${PYTHON_PN}-py \
27 ${PYTHON_PN}-setuptools \
28 ${PYTHON_PN}-six \
29 ${PYTHON_PN}-toml \
30 ${PYTHON_PN}-wcwidth \
31"
32
33ALTERNATIVE:${PN} += "py.test pytest"
34
35NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
36ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
37
38ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
39ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
40
41BBCLASSEXTEND = "native nativesdk"