blob: 669f42b8e7cc3d8cedcc8856d91a0db0f0dc19e7 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "High-Performance Asynchronous HTTP Client Library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "The Apache Serf library is a C-based HTTP client library built upon the Apache \
3Portable Runtime (APR) library. It multiplexes connections, running the \
4read/write communication asynchronously. Memory copies and transformations are \
5kept to a minimum to provide high performance operation."
Andrew Geissler95ac1b82021-03-31 14:34:31 -05006HOMEPAGE = "http://serf.apache.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
8 file://norpath.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +08009 file://env.patch \
10 file://0001-Fix-syntax-of-a-print-in-the-scons-file-to-unbreak-b.patch \
11 file://0002-SConstruct-Fix-path-quoting-for-.def-generator.patch \
12 file://0003-gen_def.patch \
13 file://0004-Follow-up-to-r1811083-fix-building-with-scons-3.0.0-.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040014 file://SConstruct.stop.creating.directories.without.sandbox-install.prefix.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050015 file://0001-buckets-ssl_buckets.c-do-not-use-ERR_GET_FUNC.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080016 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017
18SRC_URI[md5sum] = "370a6340ff20366ab088012cd13f2b57"
19SRC_URI[sha256sum] = "549c2d21c577a8a9c0450facb5cca809f26591f048e466552240947bdf7a87cc"
20
21LICENSE = "Apache-2.0"
22LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
23
Brad Bishop15ae2502019-06-18 21:44:24 -040024inherit scons
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
Brad Bishop15ae2502019-06-18 21:44:24 -040026DEPENDS += " openssl apr apr-util util-linux expat"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027
Brad Bishop15ae2502019-06-18 21:44:24 -040028EXTRA_OESCONS = " \
29 LIBDIR=${libdir} \
30 --install-sandbox=${D} \
31 CC="${CC}" \
32 CFLAGS="${CFLAGS}" \
33 LINKFLAGS="${LDFLAGS}" \
34 APR=`which apr-1-config` \
35 APU=`which apu-1-config` \
36 OPENSSL="${STAGING_EXECPREFIXDIR}" \
37 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038
Andrew Geissler09209ee2020-12-13 08:44:15 -060039# scons creates non-reproducible archives
Patrick Williams213cb262021-08-07 19:21:33 -050040do_install:append() {
Andrew Geissler09209ee2020-12-13 08:44:15 -060041 rm ${D}/${libdir}/*.a
42}
43
Andrew Geisslerb7d28612020-07-24 16:15:54 -050044BBCLASSEXTEND = "native nativesdk"