Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc" |
| 2 | HOMEPAGE = "https://github.com/cminyard/gensio" |
| 3 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \ |
| 5 | file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \ |
| 6 | " |
| 7 | |
| 8 | SRCREV = "95ec1ab31ee97411fc37156d12061adcf0331598" |
| 9 | PV = "1.5.3+git${SRCPV}" |
| 10 | |
| 11 | SRC_URI = "git://github.com/cminyard/gensio;protocol=https \ |
| 12 | file://0001-filter-Rename-some-variables-to-tr_stdxxx.patch \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit autotools |
| 18 | |
| 19 | PACKAGECONFIG ??= "openssl tcp-wrappers" |
| 20 | |
| 21 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl" |
| 22 | PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers" |
| 23 | PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig" |
| 24 | |
| 25 | EXTRA_OECONF = "--without-python" |
| 26 | |
| 27 | RDEPENDS_${PN} += "bash" |